Please make sure you meet the prerequisites prior to installing the theme.

Configuration#

Since 0.68.0, HBS requires the following configurations are be set.

1[build]
2  writeStats = true
1build:
2  writeStats: true
1{
2   "build": {
3      "writeStats": true
4   }
5}

Build Tools#

Tool Version Description
Git Version Control Systems
Hugo extended version 0.97.0 or above.
Node.js and NPM NodeJS 16 or above used for installing CSS and JS dependencies, and building the assets.
Go 1.12 or above required only when installed as a Hugo Module.

We recommend using the latest version of those tools.